关于 nvm 只有 iojs 版本的问题

Mac 可以用 nvm 方便地管理 node.js,但执行 nvm ls-remote 时(貌似耗时也很长),只能看到 io.js 的版本,自然也无法安装 node.js。如图:

QQ20170117-0@2x

本以为是 nvm 拒绝支持 node.js,在了解了 node.js 和 io.js 的渊源之后,觉得事有蹊跷。查下来估计是 GFW 的问题,真是汗颜。连接 VPN 之后,nvm ls-remote 可以正常看到 node.js,安装指定版本即可。

未连 VPN 的情况下,只开 Shadowsocks 全局模式也未能解决。严格来说我是用 Shadowsocks + VPN 情况下才搞定的。至于 Stack Overflow 上貌似说因为 Mac 没更新 HTTPS 证书的,没验证过。

做个码农也是心累。